Unable to connect to the configured development web server


A few days ago I had to format my computer for some problems with Windows 10, when reinstalling Visual Studio 2015 and trying to run some web services projects, it sends me that error message that I do not completely know what it is. I hope someone can help me with this, I urge those services.


IIS version:

Update 2

asked by Richard 13.10.2016 в 18:22

4 answers


I have found the solution to my problem, it is as simple as deleting a file that is in:


[project] .vs \ applicationhost.config

And with this I was able to run my Web services again

answered by 13.10.2016 / 21:40

In this case, there are two actions to take:

  • Register the service as a WebSite in your local IIS, the path of the WebSite must be the same path where your solution exists, this with the aim of debugging the most updated DLLs when debugging.
  • Run Visual Studio with administrator privileges.
  • answered by 13.10.2016 в 19:47

    This is what Microsoft reports on this error:

    • An attempt was made to debug a .NET web application that was copied to a different team, changed its name manually or moved.
    • There are not enough IIS connections. For more information about How to implement a website in IIS, see Create a website.
    • If you try to debug an ASP.NET application, see Publish to IIS for get instructions on how to deploy to a remote computer Run IIS 8 or higher, or Remote ASP.NET Debugging on a computer IIS 7.5 Remote for instructions on implementation on a remote computer that is running IIS 7.5.

    Source: link

    answered by 13.10.2016 в 19:22

    As an addition I tell you all the process that was done and which in my case made it work. I tried all the answers given and none worked.

    Even restart Visual Studio 2017, the computer, switch between IIS Express to IIS Local (in the project configuration), ... but nothing ...

    Finally, try

    Delete [project] .vs \ applicationhost.config stop the IIS, start it and just in case to restart it and finally it worked for me ...

    answered by 20.09.2018 в 08:52