VirtualHost force https instead of http with .dev domain


I have created a Virtualhost for a project.

In httpd-vhosts.conf :

<VirtualHost *:80>
      DocumentRoot "C:/xampp/htdocs/"
      ServerName localhost
<VirtualHost *:80>
       DocumentRoot "C:/xampp/htdocs/.../public"

And in hosts :    

When I log in to localhost redirects without problems to http://localhost/dashboard

But when I try to enter for some reason it forces and pulls error that "The connection is not private" .

Interestingly, in Chrome and Firefox this happens. But in Internet Explorer no (being able to see the page as it should be). Does anyone know why?

I have done it following the tips for Virtualhosts of the Xampp dashboard.

I've tried everything I found in google, and I've tried different keywords without coming up with a solution.

asked by RGC 30.07.2018 в 23:29

1 answer


Chrome and Firefox use filters to force the link in top level domains, such as .com , .org , .net , etc. using a link


.dev is a tld (Top Level Domain) , so why that forces the link . (This tld is always forced because it seems to be from Google)

ref: link

Try changing it to don.test , don.local or don.devlocal

If you are interested, you can read this article in English about it:

answered by 31.07.2018 / 17:07