Does not load localhost: 81, Disadvantages with port change 80 to 81


Friends, I changed the port configuration localhost: 80 to localhost: 81 in the following files: httpd.conf: Listen 81 ServerName localhost: 81

In the configuration (config) in xampp > in Services and port services > where it says main port to 81, but when I restart and place localhost does not load anything, I rebooted the PC and nothing either, what can it be?

I get this:

asked by Angel Zambrano 02.02.2018 в 20:00

3 answers


As I mentioned in the comments, you can access the localhost.

Like this:



This is because you have changed the port number to access the local server, since by default it is assigned with port 80. So every time you make a port change you will have to access it with the port number you placed.

answered by 03.02.2018 в 06:02

Well, having changed in both places, it seems strange to me that it does not work for you. In the httpd.conf file there are three sites where you have to change it: Listen Listen 80 ServerName localhost: 80

answered by 02.02.2018 в 20:32

Friends, nothing like finding the answer yourself, well, at least this is a solution. because the localhost modified under another port, in this case localhost: 81, if it seems as annoying as my having to place: 81 everything there is a way to avoid that, how? in this way:

First we enter Control Panel > Center of networks and shared resources (if you use W10, W8.1 or W7).

Then we click on Connections> LAN Settings:

Then we check the box to use a proxy for LAN and Advanced Options.

And it is precisely here where we place the localhost or place the local ip with port 81. If we put it in the other protocols, the internet will not work, at least that happened to me.

But at least it works for me without having to place localhost: 81

answered by 07.02.2018 в 02:23