I can not install the Laravel package.js in Node JS

1

My intention is to install the package that Laravel has in Node.js.

This is the content of my package.js file:

{
  "private": true,
  "scripts": {
      "dev": "gulp watch",
      "prod": "gulp --production"
   },
"devDependencies": {
    "bootstrap-sass: "^3.3.7",
    "gulp": "^3.9.1",
    "jquery": "^3.1.0",
    "laravel-elixir": "^6.0.0-9",
    "laravel-elixir-vue": "0.1.4",
    "laravel-elixir-webpack-official": "^1.0.2",
    "lodash": "^4.14.0",
    "vue": "^1.0.26",
    "vue-resource": "^0.9.3"
   }
}

In the terminal of Node.js I put the command npm install and this error marks me:

c:\xampp\htdocs\[proyecto]> npm install
npm ERR! code E400
npm ERR! 400 Bad Request: [email protected]^3.9.1

...

I've already tried:

  • reinstall Node.js.
  • delete the node_modules folder from my project several times because I did not install the laravel-elixir .

What else can I do?

    
asked by Kris Zamudio 04.07.2017 в 05:19
source

1 answer

2

I was able to install the node modules without any problem. The only thing I see strange in what you are posting is that you have an error in the package.json

You are missing quotes in the "bootstrap-sass": "^ 3.3.7"

{
  "private": true,
  "scripts": {
      "dev": "gulp watch",
      "prod": "gulp --production"
   },
"devDependencies": {
    "bootstrap-sass": "^3.3.7",
    "gulp": "^3.9.1",
    "jquery": "^3.1.0",
    "laravel-elixir": "^6.0.0-9",
    "laravel-elixir-vue": "0.1.4",
    "laravel-elixir-webpack-official": "^1.0.2",
    "lodash": "^4.14.0",
    "vue": "^1.0.26",
    "vue-resource": "^0.9.3"
   }
}

Greetings!

    
answered by 04.07.2017 в 06:32