I can not load my app on the iPhone


I do not know what has happened but I throw the following error, I tried everything, but from one moment to the next it became confused and it does not work for me to send my app to the iPhone: (

Now it tells me the following:

And when I go to the key ring he says:

It happened that my PC restarted and changed the date and now to the year 2000, but I set the time and it's fine but it's still the same.

Afterwards, it worked for me to compile, to delete the certificate, to turn off the PC, delete all the app from the Apple website and then at the end I worked by magic. xD

But he gave me this error:

  dyld: Library not loaded: @rpath/libswiftCore.dylib
  Referenced from: /var/mobile/Containers/Bundle/Application/3FC2DC5C-A908-42C4-8508-1320E01E0D5B/Stylist.app/Stylist
  Reason: no suitable image found.  Did find:
    /private/var/mobile/Containers/Bundle/Application/3FC2DC5C-A908-42C4-8508-1320E01E0D5B/testapp.app/Frameworks/libswiftCore.dylib: mmap() errno=1 validating first page of '/private/var/mobile/Containers/Bundle/Application/3FC2DC5C-A908-42C4-8508-1320E01E0D5B/testapp.app/Frameworks/libswiftCore.dylib'

And according to this post , the solution is like this and I I work:

rm -rf "$(getconf DARWIN_USER_CACHE_DIR)/org.llvm.clang/ModuleCache"
rm -rf ~/Library/Developer/Xcode/DerivedData
rm -rf ~/Library/Caches/com.apple.dt.Xcode
asked by albertcito 25.05.2016 в 23:16

2 answers


Remove related certificates and provisioning, both locally and in the developer account. Do not worry that your apps will not stop working. Once erased, re-generate them again and that's it.

answered by 25.05.2016 / 23:37

First, security certificates require that you have the correct date and time.


Please verify that your device's clock is properly set

Remove the certificates and generate new ones.

answered by 25.05.2016 в 23:39