IIS Server 8.5 Adds characters to the URL


I recently installed an IIS 8.5 in W 8.1, and as I was progressing I found the details of bad configuration on my part. Now I have an inconvenience at the time of wanting to access some of the web pages hosted on this server.

Either you want to access the home page or another page that I have hosted on the server to the URL is added a string of characters that I do not know why?.

For now I am accessing a LAN, that is, between an internal PC network.

For example, the IP of my server is: when in the browser of one of the PCs of my LAN I write I access the homepage hosted on my server but instead of this appearing to me


I get this:

link (S (uxkuxpbd4mmcax35jny3omdg)) /default.aspx

that is, you are adding this string of characters: (S (uxkuxpbd4mmcax35jny3omdg))

What I have noticed is that the soup of letters and numbers varies, for example:

Once is this (S (nhsvypb2jf2peqadugoqbydj))

another is (S (y2iowieagyyzh15tswiigecx))

What I had done at the time is to generate a self-signed certificate and delete the one that came by default.

Either enter from the server itself or from any PC on my LAN.

What will be the problem?

asked by cce 07.04.2017 в 14:42

2 answers


Excato frikinside. Solved.

The problem: my original application ran in NetFramework 3.5 then I compiled it to NetFramework 4.5 and there I changed the thing. Why? In my original project to wbe.config I had added it so that the session closes at 30 min when it does not detect activity. Then when I ran it with NetFramework 4.5 the project was updated and two parameters were added :. I made the modification you told me and the problem was solved.

Now I consult you: what does cookieless="true" mean? why do you add those characters?

Thank you very much for the help .-

answered by 21.04.2017 в 15:25

It seems that in the configuration of the IIS or in web.config of the application you have enabled the session mode cookieless . You can read more information about this configuration in the documentation of the msdn

You could check if in the web.config you have the following line or similar:

<sessionState cookieless="true" />

Marking it as false or removing the attribute for that configuration should solve the problem you currently have.

answered by 20.04.2017 в 10:21