Error executing laravel project cloned from git


I cloned a project of a repo git. When I try to open it ( link ) it tells me the following:


Fatal error: Uncaught Error: Class 'Illuminate \ Foundation \ Application' not found in C: \ xampp \ htdocs \ pikum.mapu \ bootstrap \ app.php: 14 Stack trace: # 0 C: \ xampp \ htdocs \ pikum.mapu \ public \ index.php (38): require_once () # 1 {main} thrown in C: \ xampp \ htdocs \ pikum.mapu \ bootstrap \ app.php on line 14

And that project was done by me and it was fine, I get the same error when running php artisan serve. What could it be? I do not know if something should be done before running a laravel project

asked by Naoto Amari 13.02.2018 в 14:01

1 answer


is because when clones of the official repository , the dependencies are not ready; that is, they do not exist within the project but it is finally solved by doing

composer install

Where do you know which packages or dependencies to install?

Well at the root of your project there is a file called composer.json within which there is a section that says for example require-dev which are the required dependencies for development and will begin to download

inside the root folder; I'll give you as an example that this is the same situation that arises when you are working on a project built on NodeJS if you do not

npm install

same mark errors.


answered by 19.02.2018 / 02:50