DO NOT redirect to HTTPs some services with TRAEFIK


I have mounted tráfik in Docker with the following configuration in TOML :

defaultEntryPoints = ["http", "https"]

  address = ":80"
    entryPoint = "https"
  address = ":443"
      certFile = "/certs/fidesol.crt"
      keyFile = "/certs/fidesol.key

With it, everything is redirected to HTTPS.

The fact is that I have a service that by age, I need to be accessed by HTTP ...

I have tried several options in the labels but none without result. Is the configuration I mentioned possible? Or it is mandatory to create "custom frontends" and specify that this frontend is HTTP

asked by Carlos Martín 26.11.2018 в 11:45

0 answers