Swift error when running the app: dyld: Library not loaded:


When I run the app both in the simulator and on a device, it closes and shows me the following error:

dyld: Library not loaded: @ rpath / DatePickerDialog.framework / DatePickerDialog   Referenced from: /Users/bimo/Library/Developer/CoreSimulator/Devices/930D181E-3A41-4086-AA01-FEF52B640845/data/Containers/Bundle/Application/906578C2-C547-4917-A1FE-9D9778E67857/Bimo.app/Bimo   Reason: image not found

I have tried several things, delete all the pods and reinstalled them, delete the framework that is under the general tab and I added it again. Delete the folder of derivedData and I re-indexed everything again and it keeps giving me the error.

I even created a new user on the Mac, I downloaded the repo again and the error does not go away.

I thought it could be a certificate error, but enter with another user and give the same error. I hope someone can help me. Thank you very much.

asked by Tamara Arleo 25.09.2018 в 21:58

1 answer


Have you already tried deleting the derived data, cleaning the project and rebuilding it?

answered by 26.09.2018 в 20:49