Problem executing an .exe with pyinstaller


Bunas, I tell you my problem, when working with the package anaconda3-4.2.0 x86 for windows 10 x64 I could generate my .exe program and it worked correctly. Then I had to format my PC for some problems and install the same version of widows 10 x64, but with anaconda anaconda3-5.0.0 x86 and the same script built by pyinstaller I did not execute. Moving to the old version of anaconda, that is 4.2.0 , the .exe generated by pyinstaller will not work again.

Then when generating a test program by calling the same packages that my program uses, the one that generates the problem is pyqt5 , since it worked correctly in the same version 4.2.0 x86 .

Below we see the error message that appears when trying to run the program.


"   This application failed to start because it could not find or load the Qt > platform plugin "windows"   in "".


Reinstalling the application may fix this problem.

The output of pyinstaller is as follows:


500 INFO: PyInstaller: 3.3


500 INFO: Python: 3.5.2


500 INFO: Platform: Windows-10-10.0.10586-SP0

These are the warning generated by pyinstaller:

Now analyzing the .dll of the .exe that works vs the .exe that does not work with the command:



I see that the file that works has the following packages:









While the does not work generates only the following:





What should I do to solve my problem, since the version that works has errors in the code.

Thanks for reading.

asked by Marcelo S. 12.12.2017 в 20:13

1 answer


ami something similar happened to me a long time ago, it is necessary to look for the problem when compiling the pyqt plugins dll. but I recommend that you use pyqt4 that has greater pyinstaller compatibility. validates that all dependencies are installed link

answered by 13.12.2017 / 02:55