aapt.exe finished with non-zero exit value 1 Android Studio


I updated my Android Studio from version 2.3.3 to version 3.1. He gave me several problems that I solved. However, there is one that has been impossible for me. The error says like this:

Process 'command 'C:\Users\User\AppData\Local\Android\Sdk\build-tools.0.1\aapt.exe'' finished with non-zero exit value 1

Fails at this point:

I have read that there are two possible solutions:

  • android.enableAapt2 = false in gradle.properties. This does not work for me It only shows me a warning at the beginning.
  • Build-> Clean project, Build-> Rebuild Project This, too, I still skip the same error.
  • If someone knew what could be happening. Thank you very much.

    asked by Diego Montagud 29.01.2018 в 19:25

    1 answer


    If your project worked without problem and you made an update to Android Studio

    it should be sufficient to invalidate the cache of Android Studio with the option:

    Invalidate Caches / Restart

    The error you mention


    aapt.exe '' finished with non-zero exit value 1

    is related is also related to a problem in the resources, I suggest you check:

    Android, "R's" red throughout the code

    answered by 11.12.2018 в 02:55