Mens. INSERT SQL error


I have configured a user with INSERT permission for Customers table: GRANT INSERT ON CLIENTS TO userX

executing the query:

return the following notice:

Mens. 102, Level 15, State 1, Line 1 Incorrect syntax near ')'.

(1 affected rows)

In the table the line is inserted correctly, to check that it is not syntax failure when I execute the same query with the user 'sa' is inserted and does not return any error

How can I solve it? ..

asked by brahim 29.08.2016 в 15:57

2 answers


This error message:


Mens. 102, Level 15, State 1, Line 1 Incorrect syntax near ')'.

It means that you may have a string that is closed in your query or have some character, which may cause your query to be cut.

In this case you have non-printable characters, you can see it here:

answered by 29.08.2016 в 16:39

Good morning,

thank you all for your help ..

After reviewing all the possibilities that you have commented: Triggers, syntax ..etc. everything is correct and there are no triggers that can affect these permissions. I have tried to delete and re-give the INSERT permission to the user several times and the next day it worked for me the first time without any error with the same query .. the SQL service has not been restarted or anything .. I can not give an explanation of the solution because the initial error does not make sense.


answered by 01.09.2016 в 13:56