Error compiling CyanogenMod


I'm trying to compile CyanogenMod (an Android 'fork') and I get a strange error code hundreds of times in different lines. The error is as follows:

external/libcxx/src/strstream.cpp:326: error: no se admite la reubicación 43
external/libcxx/src/system_error.cpp:178: error: no se admite la reubicación 43
external/libcxx/include/stdexcept:112: error: no se admite la reubicación 43

I've looked around and I can not find anything, I'm pretty lost.

There are no errors in the code, it is in the stable branch of the project.

The error is thrown by the linker to be more precise.

There is also another very similar error linking to the rest of the compiled code archivo.o that indicates:

no se admite la reubicación 43 contra el símbolo global vtable for std::__1::moneypunct_byname<wchar_t, false>

The same error occurs many times in different locations:

no se admite la reubicación 43 contra el símbolo global std::__1::locale::id::__init()

On the other hand, in the code, some of the lines in which the error is triggered are:

logic_error::~logic_error() _NOEXCEPT {}
if (__flag.__state_ != ~0ul)

The truth is that I do not know what to try ... Any suggestion would come very well! Thanks

asked by Lucho Rocha 12.05.2016 в 11:43

1 answer


If there is still someone out there with the problem unsupported reloc 43 (English)

It seems to be what happens to the OP as it is a link problem and it is precisely the same error.


As they comment on the site in English (and if this is the same case), it is about applying the following patch .

They indicate that for Android Lollipop or earlier versions it is important to add the -no-integrated-as switch when applying the patch. For Marshmallow android versions onwards it would not be necessary.

answered by 21.09.2017 в 16:40