I can not test the application in Android Studio


It happens to me that when I click on the Run button to try the application I do not see anything

but I do not see anything, I'm supposed to always get this window when I run my projects, but specifically in the project I'm in, I do not see this window or anything or an error message or anything:

What can I do? Why can not I run the app for that project?

asked by Jose Eduardo Espinoza 09.04.2017 в 20:24

2 answers


Without support of VT-x and SVM in your processor it is always convenient to run the application on a real device (in your case the Sony D5306).

To make that work, make sure of the following:

  • Your device is connected by USB cable
  • Your device has debugging enabled (configuration-> developer options)
  • Your device is connected as USB Storage (not MTP or PTP)

If you checked on your device that you meet all these conditions, check the settings in Android Studio:

  • Review Run-> Edit Configurations-> Android App-> app
  • On the General tab, choose Target "Open ... Target Dialog" or "USB Device"
  • Make sure "Use same device for duture launches" is unchecked

This way you should open the dialog when you press the debug symbol.

Check carefully what it says below in your Android Studio SDK when you do it. Taking into account that your processor does not have support for virtualization makes it likely that you do not work in a system with tremendous performance. Esp can mean that the build takes its good time at times, especially if you do not have very large memory at your disposal. It may be that you are going to have a few minutes of patience for the build, but Android Studio should inform you about what is going on while.

If these steps do not solve the problem, check what you get in the Event Log when you start debugging.

answered by 09.04.2017 / 21:00

Only install HAXM (Hardware Accelerated Execution Manager)




answered by 10.04.2017 в 06:50