Error accessing virtual host in xampp


I have created a virtual host with Apache and XAMPP. Locally I can access, but if I try to enter from another computer and in the same network does not access.

<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs/project"
   ServerName devel.project
    ServerAlias devel.project
SSLEngine on
SSLCertificateFile conf/ssl.crt/server.crt
SSLCertificateKeyFile conf/ssl.key/server.key
    <Directory "C:/xampp/htdocs/project">
Options Indexes FollowSymLinks MultiViews
AllowOverride All

What could be the error?

asked by Andres Guillermo Castellanos A 17.06.2016 в 17:04

1 answer


Here I will leave the steps that I follow to create my virtual hosts ( WINDOWS ).

1) Go to the following address


C: \ xampp \ apache \ conf \ extra

2) Modify the link file by adding the following to the end of the file and replacing the uppercase text:

<VirtualHost *:80> DocumentRoot "DIRECCION DE TU PROYECTO" ServerName EJEMPLO.LOCALHOST <Directory "DIRECCION DE TU PROYECTO"> Options Indexes FollowSymLinks ExecCGI Includes Order allow,deny Allow from all Options All AllowOverride All Require all granted </Directory> </VirtualHost>

3) Go to the address


C: \ Windows \ System32 \ drivers \ etc

and edit the file hosts , after where it says: localhost

Near line 23, Add the following: EJEMPLO.LOCALHOST

4) Then, Save and replace the file, Now restart the apache from XAMPP or MAMP, and it's ready.

answered by 20.01.2018 в 17:02