Problem with bluetooth in slackware 14.2 current


After having updated the kernel to version 4.4.6, both the bluetooth GUI and some other things (eg connecting a device via bluetooth) do not work.

The things I tried were the following:

  • reinstall the bluetooth package (unsuccessfully)
  • neither uninstall it and reinstall it
  • restart the service

Being a user gives me:

Starting Bluetooth services: 

 bluetoothd hciconfig sdptool hciattach D-Bus setup failed: Connection ":1.58" is not allowed to own the service "org.bluez" due to security policies in the configuration file

And being root starts it well without error or with sudo it starts well too.

dmesg | grep -i blue
[ 6.623881] Bluetooth: Core ver 2.21
[ 6.623897] Bluetooth: HCI device and connection manager initialized
[ 6.623901] Bluetooth: HCI socket layer initialized
[ 6.623903] Bluetooth: L2CAP socket layer initialized
[ 6.623908] Bluetooth: SCO socket layer initialized
[ 15.270804] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 15.270808] Bluetooth: BNEP filters: protocol multicast
[ 15.270812] Bluetooth: BNEP socket layer initialized

hcitool dev
hci0 4C:EB:42:7F:C1:6D

rfkill list bluetooth
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

I do not know what to try anymore, it used to work great, but not now, and I do not intend to downgrade!

asked by CL45H 29.03.2016 в 03:42

1 answer


I think you started a thread here where they explain the solution (and I expose it for future references) that is very close to what you already commented on your question but with a specific order that is very important to maintain:

  • For the process of bluetoothf with:

    /etc/rc.d/rc.bluetooth stop

  • Remove the package bluez

    removepkg bluez

  • Reinstalls the bluez package:

    slackpkg update


    slackpkg install bluez


    /etc/rc.d/rc.bluetooth start

    And solved.

    Also when you do step 2 of eliminating the bluez you will see many messages (do not worry about that) that can be informative in case there is an error but even if it is, as long as you uninstall, it does not matter.

    answered by 30.06.2016 в 09:43